View Single Post
Old 12-04-17, 09:09 PM   #1 (permalink)
Umbrax
Member
 
Join Date: Oct-2017
Location: Richmond
Posts: 12
Country:
Colombian Rainbow Boa Wonít Eat. Tried Everything. Need Help.

My Colombian rainbow Boa wonít eat no matter what I do. I got him one month ago from bhb reptiles as a baby and I did everything everyone says to do when you first get a snake. I had the enclosure setup prior with proper temps and a numerous amount of hides, and when I got him I put him in and left him alone for a week before even attempting to feed him. After a week I tried feeding a fuzzy to him and he showed absolutely no interest, I waited a few days and then tried again, still nothing. He doesnít even acknowledge it. So after that I waited a week and tried again, this time braining the mouse, heating it up hot, and coating it in chicken broth. Still nothing. No interest. Iíve tried once every 3 days from then, trying new methods i find online to no avail. Itís been a little over a month now and the snake still shows absolutely no interest in food. The tempts are where they need to be, cool side 75 hot spot 85-87. Humidity is always over 70%. in addition, the snake shed fully and nicely with eye caps a week after I got him so I know heís not in shed currently. I cant try rats because they are too big for him, even pinkies. Hereís a full list of the things Iíve already tried:

Braining the mouse, Blow drying the mouse, Scenting the mouse, Cutting open the belly of the mouse, moving the snake to a smaller enclosure with more hides to help with security, leaving the mouse overnight, placing the snake into a small tub with the mouse overnight, wetting the mouse in very hot water prior to offering, offering smaller and larger sized mice of different colors.

What the hell am I supposed to do now. Iím scared for my snake, and I just want him to eat so I know heís ok. This whole thing is stressing me out. Iíve made absolute sure my husbandry is on point and I did a TON of research before getting the snake in the first place so what in the world could I be doing wrong.
Umbrax is offline   Reply With Quote
Login to remove ads